Unable to Login to Amazon Environment | Login Issue

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Aug 25, 2022 - 06:53 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2022 - 05:39 PDT

Identified

The issue has been identified and a fix will be implemented soon.
Posted Aug 25, 2022 - 04:44 PDT

Investigating

We are currently investigating an issue that is causing Amazon Environment users the inability to log in. We will be providing updates soon.
Thank you for your patience and cooperation. Apologies for any inconvenience caused.
Posted Aug 25, 2022 - 03:46 PDT
This incident affected: Expense Audit (Expense Audit).