Mastermind Analytics is Down for few customers
Incident Report for AppZen
Resolved
As per the latest update, we are happy to confirm that the issue with Mastermind Analytics has been resolved.
Posted Feb 23, 2023 - 01:20 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 22, 2023 - 23:30 PST
Update
Our engineers are addressing the issue and working on a solution for the identified issue with Mastermind Analytics. We will continue to provide further updates. Thank you for your cooperation and patience.
Posted Feb 22, 2023 - 22:05 PST
Identified
We have identified an issue with Mastermind Analytics. Only a few customers may experience an issue accessing Mastermind Analytics and our team is working on resolving the issue on high priority. We will continue to provide further updates.
We apologize for any inconvenience caused due to this.
Posted Feb 22, 2023 - 20:16 PST
This incident affected: Mastermind Analytics (Mastermind Analytics).