Invoice WORKBENCH Navigation Issue

Incident Report for AppZen

Resolved

This issue has been resolved.
Posted Feb 04, 2025 - 09:47 PST

Identified

Workbench only shows the result of 1st page and does not move to the following pages.
Posted Feb 04, 2025 - 09:09 PST
This incident affected: AppZen Autonomous AP (AAA API).