Appzen EA & AAP : Latency in actioning reports or processing invoices

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 07:51 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 05:39 PST

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 04:16 PST

Investigating

We have identified an issue where users may be unable to action reports or invoices in Appzen due to increased latency.

The team is actively working on the issue and will share updates as more information becomes available.
Posted Mar 02, 2026 - 03:42 PST
This incident affected: Expense Audit (Expense Audit) and AppZen Autonomous AP (Invoice Processing).