System Slowness Impacting Report Auditing and Invoice Processing, ingestion and email notification

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Dec 24, 2025 - 15:49 PST

Update

We are continuing to investigate this issue.
Posted Dec 24, 2025 - 09:58 PST

Update

We are continuing to investigate this issue.
Posted Dec 24, 2025 - 09:51 PST

Update

We are continuing to investigate this issue.
Posted Dec 24, 2025 - 09:50 PST

Investigating

AppZen is currently experiencing performance degradation, resulting in slowness during report auditing and invoice processing, invoice ingestion and email notification. Customers may observe increased processing times, delays in audit completion, or slower-than-usual system responses while submitting or reviewing reports and invoices.

Our Engineering team is actively investigating the issue and working to restore normal performance at the earliest. Further updates will be shared as more information becomes available.
Posted Dec 24, 2025 - 04:59 PST
This incident affected: Expense Audit (Expense Audit), AppZen Autonomous AP (Invoice Processing), and AppZen Inbox.