Report Ingestion Issue for Workday Platform Users
Incident Report for AppZen
Postmortem

Hi,

We sincerely apologize for the report ingestion failure issue caused for Workday platform users. We are pleased to inform you that, we have identified the root cause along with remediation for the issue as below.

Root Cause: AppZen has deployed a new feature to retain the auditor feedback for resubmitted reports. During resubmit, for Retain Auditor Feedback feature, code tries to compare the report lines from the previously submitted version of the same report. For workday customers, the external line id value was coming as blank and it was causing to report ingestion failure. For the workday, we temporarily turned this feature off which fixed the report ingestion issue.

Remediation: We are in process of enhancing the code with more rigorous testing in order to make this feature available for Workday platform customers.

Regards,

AppZen Support Team

Posted Oct 28, 2021 - 15:52 PDT

Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 16:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2021 - 12:25 PDT
Update
Hi,

Our engineers have identified the issue for Workday customers and the hotfix has been tested successfully. Currently, our engineers are working towards deploying the fix. We will keep updated on the progress of deploying the fix.

Apologies for the inconvenience caused.

Regards,
AppZen Support Team
Posted Oct 20, 2021 - 17:46 PDT
Identified
We are seeing intermittent report ingestion issues for Workday customers and our Engineers are actively working to fix this issue.
Posted Oct 20, 2021 - 14:53 PDT
This incident affected: Expense Audit (Expense Audit).