AppZen Not Accessible - US Region
Incident Report for AppZen
Resolved
Hi,

We are happy to inform you that the access issue with AppZen has been resolved.

Regards,
AppZen Support Team
Posted Aug 29, 2021 - 21:20 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2021 - 20:32 PDT
Identified
This is to inform you that, we have observed some performance issues with AppZen US Region. You might observe some issues while accessing the application as well as Resetting passwords.

Our team is currently working on resolving the issue with high priority. We will be sure to update you on your progress.

Thank you for your cooperation.
Posted Aug 29, 2021 - 20:00 PDT
This incident affected: Expense Audit (Expense Audit).