Delays in Expense Report Ingestion

Incident Report for AppZen

Resolved

This incident is resolved
Posted Nov 13, 2025 - 00:23 PST

Update

Thank you for your continued patience.

While the earlier fix led to an improvement and a reduction in the pending report backlog, we’ve observed a recent increase again. Our team has implemented additional optimisations to improve processing speed and continues to monitor report flows closely.

We will provide the next update once we confirm consistent performance or if further action is required.
Posted Nov 12, 2025 - 07:30 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 17:38 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 11, 2025 - 17:38 PST

Investigating

We are currently investigating this issue.
Posted Nov 11, 2025 - 15:40 PST
This incident affected: Expense Audit (Expense Audit).