Appzen : Users getting logged out of Appzen

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 18:13 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 16:04 PDT

Update

We are still investigating the issue on the highest priority and working to resolve it as soon as possible.
Our sincere apologies for the inconvenience, and thank you for your continued patience.
Posted Oct 28, 2025 - 14:50 PDT

Update

We are continuing to investigate this issue.
Posted Oct 28, 2025 - 13:30 PDT

Update

We are continuing to investigate this issue.
Posted Oct 28, 2025 - 13:05 PDT

Update

We are investigating the issue and will keep updating the progress.
Apologies for the inconvenience caused.
Posted Oct 28, 2025 - 13:02 PDT

Investigating

Users may be unable to log in to AppZen and are getting logged out automatically.
Posted Oct 28, 2025 - 12:50 PDT
This incident affected: Expense Audit (Expense Audit) and AppZen Autonomous AP (Invoice Processing).