Invoice Processing Delays

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 04:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 03:12 PDT

Investigating

We’re aware of the slowness currently impacting invoice processing, which is causing invoices to remain in the Processing stage. Our team is actively working on resolving this, and we’ll keep you updated as soon as performance stabilizes.
Posted Oct 07, 2025 - 14:04 PDT
This incident affected: AppZen Autonomous AP (Invoice Processing).