AppZen is not reading statements for AP Inbox

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 05:48 PST

Monitoring

A fix has been implemented and we are monitoring the same.
Posted Dec 01, 2025 - 23:00 PST

Investigating

We are currently investigating the issue.
Posted Dec 01, 2025 - 22:36 PST
This incident affected: AppZen Inbox.