AAP - Invoice Processing Latency

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 23:10 PST

Monitoring

A fix has been implemented, and we are monitoring it.
Posted Jan 22, 2026 - 21:55 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 22, 2026 - 11:41 PST

Investigating

We are currently experiencing latency in invoice processing, which may result in some invoices appearing stuck in a state.

Our teams are actively investigating and working to resolve the issue. We will continue to provide updates as progress is made.

Thank you for your patience, and we apologize for the inconvenience.
Posted Jan 22, 2026 - 07:41 PST
This incident affected: AppZen Autonomous AP (Invoice Processing).