Autonomous AP - Invoices stuck in Processing
Incident Report for AppZen
Resolved
We have Re-run the audit for all the invoices and marking the Incident as resolved
Posted May 06, 2024 - 16:31 PDT
Update
We have fixed the invoices stuck in Validating state
We are currently working on the invoice in Processing state
Posted May 06, 2024 - 15:39 PDT
Update
We are currently working on the invoice in Validating state
Posted May 06, 2024 - 14:15 PDT
Update
We have fixed all invoices stuck in Approval Workflow
We are currently working on the invoice in Validating state
Posted May 06, 2024 - 13:12 PDT
Monitoring
A fix has been implemented & we are monitoring the same.
Posted May 06, 2024 - 11:44 PDT
Identified
We have identified an issue with AppZen's Invoice Processing.

The team is currently addressing the matter as a top priority. The Incident Response Team has been activated and is probing the root cause of the incident. We will provide you with updates on the progress.
Posted May 06, 2024 - 11:38 PDT
Monitoring
A fix has been implemented & we are monitoring the same.
Posted May 06, 2024 - 09:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 06, 2024 - 08:46 PDT
Investigating
We have identified an issue with AppZen's Invoice Processing.

The team is currently addressing the matter as a top priority. The Incident Response Team has been activated and is probing the root cause of the incident. We will provide you with updates on the progress.
Posted May 06, 2024 - 08:24 PDT
This incident affected: AppZen Autonomous AP (Invoice Processing).