Unable to login to AppZen - EU Environment
Incident Report for AppZen
Resolved
Hello,

As per the latest update, we are happy to confirm that the Login Issue with the AppZen EU region has been resolved.

Please keep monitoring the Status Page updates related to the RCA."

Regards,
AppZen Support Team
Posted Nov 11, 2022 - 02:08 PST
Investigating
Hello,

We have identified a Login issue with our EU region (https://eu.appzen.com/console/home.html#/).

We are working on resolving this issue with the highest priority and we will keep you posted on the progress on restoration.

We regret the inconnivience caused due to this.

Regards,
AppZen Support Team
Posted Nov 11, 2022 - 01:13 PST
This incident affected: Expense Audit (Expense Audit).