Expense Audit, Card Audit: Lag in Report Processing

Incident Report for AppZen

Resolved

Report processing operations have returned to normal speed. All queued reports have been cleared, and the system is functioning as expected.
If there are any residual pending reports, they will be cleared shortly.

We appreciate your patience during this incident.
Posted Oct 29, 2025 - 23:57 PDT

Update

The backlog of queued Expense and Card Audit reports has considerably reduced as processing continues.
We expect the queue to clear within the next few hours and for normal processing speeds to resume soon.
Posted Oct 29, 2025 - 02:58 PDT

Monitoring

We are currently experiencing a temporary slowdown in report processing due to an unusually high volume of reports. Our teams have implemented changes to improve processing speed, and the backlog is gradually clearing.

We appreciate your patience as we work to fully restore normal processing (this may take a few hours).

We will provide an update once performance is back to normal.
Posted Oct 28, 2025 - 23:45 PDT
This incident affected: Expense Audit (Expense Audit).