AI Analytics : EU : Dashboard Showing Incomplete Data

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 01:49 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2026 - 00:20 PDT

Investigating

We are currently investigating an issue where incomplete data is being reflected under AI Analytics for EU customers.
We are actively working on a fix. We will continue to provide updates as we make progress.
Posted Mar 10, 2026 - 05:49 PDT
This incident affected: Advanced Analytics.