Master Data Sync Issue - AAP

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 05:44 PST

Investigating

We are currently iunvestigating the issue.
Posted Nov 19, 2025 - 05:08 PST
This incident affected: AppZen Autonomous AP (Invoice Processing).