System Login Issues

Incident Report for AppZen

Resolved

The issue has been fixed however if you continue to experience an issue, we suggest that you clear your browser cache and cookies, as older cookies may still be present and clearing them should resolve the problem.

Our apologies for any inconvenience caused and thank your for your understanding as we worked to resolve.
Posted Jan 22, 2026 - 15:16 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 22, 2026 - 13:10 PST

Investigating

Some users are experiencing issues logging in to AppZen. After entering credentials and selecting Login with SSO, the session is terminated, and the landing page does not load.
Posted Jan 22, 2026 - 08:38 PST
This incident affected: Expense Audit (Expense Audit) and AppZen Autonomous AP (AAA API).