Pending Audit reports
Incident Report for AppZen
Resolved
This incident has been resolved.
Posted May 02, 2024 - 04:32 PDT
Update
We are continuing to monitor for any further issues.
Posted May 02, 2024 - 03:48 PDT
Update
We are continuing to monitor for any further issues.
Posted May 02, 2024 - 03:36 PDT
Update
We are continuing to monitor for any further issues.
Posted May 02, 2024 - 02:37 PDT
Monitoring
Reports continue to be audited by AppZen and the queue is going down. We will continue monitoring and provide further updates.
Posted May 02, 2024 - 01:03 PDT
Investigating
We have identified some delays in audit times for reports running intermittently. This is being investigated and we will update you soon with more details.
Posted May 02, 2024 - 00:33 PDT
This incident affected: Expense Audit (Expense Audit).