Invoices are failing to integrate to Oracle

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 08:33 PDT

Investigating

Currently being investigated with Oracle
Posted Jun 03, 2025 - 09:51 PDT
This incident affected: AppZen Autonomous AP (Invoice Processing).