Report workflow processing delay - Pending Auto Audit status

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 04:01 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 08, 2025 - 02:30 PDT

Investigating

While the reports are moving forward in the workflow, the processing is happening at a noticeably slow rate and we are investigating the issue.
Posted Oct 07, 2025 - 12:32 PDT
This incident affected: Expense Audit (Expense Audit).