SSO Login Issues : Okta 404 error

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 06:02 PDT

Investigating

Users attempting to log in to Appzen via SSO may experience failures due to an Okta 404 login error.

We are currently investigating the issue. Our team is actively working with the relevant services to identify the root cause and resolve it as quickly as possible.

We will share further updates as more information becomes available.
Posted Apr 06, 2026 - 04:46 PDT
This incident affected: Expense Audit (Expense Audit) and AppZen Autonomous AP (Invoice Processing).