Support Portal is down.

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 02:22 PST

Investigating

We have raised a Sev1 Ticket with Vendor
Posted Mar 06, 2026 - 01:40 PST
This incident affected: AppZen Support Portal.