Data Missing in Analytics from 23-Feb-2026

Incident Report for AppZen

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 03:38 PST

Monitoring

This issue has been identified, and a fix has been implemented. And data sync is In Progress.
Posted Feb 24, 2026 - 02:24 PST
This incident affected: Advanced Analytics.