Log-In Issue
Incident Report for AppZen
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 10:19 PST
Monitoring
A 500 Error is being reached when attempting to access AppZen. There was a partial outage for all customers we apologize for any inconvenience we are monitoring the fix.
Posted Jan 17, 2020 - 10:13 PST
This incident affected: Expense Audit (Expense Audit) and Advanced Analytics.