User login issue
Incident Report for AppZen
Resolved
Summary

There were login issues that started for some issues on Thursday 5/21/2020.

Detailed Issues:

Password reset does not work when multiple users in the system have the same email address/or if the user profile has not been activated.
SystemAdmin is no longer able to set a users' password on the UI

Resolutions

For the password reset with users sharing the same email id, we now consider login with user_id.
For the SystemAdmin we designed a new way to send a forgot password email for specific user id instead of email id.
Posted Jun 03, 2020 - 12:50 PDT
Update
We are continuing to monitor for any further issues.
Posted May 27, 2020 - 22:33 PDT
Monitoring
A fix has been put in place and we will be monitoring this throughout the next 24 hours.
Posted May 27, 2020 - 22:33 PDT
Update
The issue has been partially resolved. A fix is in place for users experiencing issues with a password reset. However, there is still a pending issue for a small subset of users trying to login but are unable to login still. This is still being investigated and we will update again shortly.
Posted May 27, 2020 - 19:00 PDT
Identified
The issue has been identified and a resolution is being put in place. We will update the status shortly.
Posted May 27, 2020 - 15:36 PDT
Update
We have identified the root cause of the issue and will be preparing an emergency patch. We will update shortly on the timing of this fix.
Posted May 27, 2020 - 13:37 PDT
Investigating
We are currently investigating a user login issue which is potentially not allowing auditors to login to the system. Also, when resetting a users password, captcha is not displaying due to back end services. This will be updated once we have more information.
Posted May 27, 2020 - 11:14 PDT
This incident affected: Expense Audit (Expense Audit).