Google Chrome Browser Login Cached
Incident Report for AppZen
Resolved
This issue has been resolved.
Posted Aug 14, 2018 - 15:04 PDT
Monitoring
We have had reports that users that are using the Google Chrome Browser could have issues logging into AppZen. We have identified that there is an issue with the browser not updating and caching the old data. In the case you are unable to login, you can clear your cache and you will be able to login to AppZen.

To clear your cache open the Google Chrome Browser --> Click on the Chrome drop down in the left hand corner --> click on clear browsing data --> check "Cached images and files --> Clear Data
Posted Aug 14, 2018 - 08:44 PDT
This incident affected: Expense Audit (Expense Audit).