Concur US Outage
Incident Report for AppZen
Resolved
Concur has updated their status page to fully operational. We will do our best to minimize any AppZen delays.https://open.concur.com/#us
Posted Mar 20, 2020 - 07:48 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 20, 2020 - 05:29 PDT
Identified
Concur is experiencing an outage in the US. We will do the best we can to keep you updated on the progress of the situation. This will effect the use of our solution. You can access the Concur Status Page here. https://open.concur.com/#public_sector
Posted Mar 20, 2020 - 05:28 PDT
This incident affected: Expense Audit (Expense Audit) and Advanced Analytics.