Delays in approving/rejecting reports
Incident Report for AppZen
Resolved
This has been resolved and processing time are coming back to normal.
Posted Nov 19, 2018 - 11:40 PST
Investigating
We are currently investigating a delay in approving and rejecting expense reports. This appears to be impacting only customers using Concur and we are working with them to resolve the issue.
Posted Nov 19, 2018 - 08:31 PST
This incident affected: Expense Audit (Expense Audit).