Delay in approving or rejecting reports
Incident Report for AppZen
Resolved
This incident has been resolved.
Posted Nov 10, 2018 - 11:00 PST
Investigating
We have identified a delay in approving or rejecting reports in AppZen. This appears to be coming from an issue on the Concur end and we have escalated this to Concur.
Posted Nov 10, 2018 - 07:15 PST
This incident affected: Expense Audit (Expense Audit).