Audit Service is partially affected
Incident Report for AppZen
Resolved
Audit service is now performing as normal.
Posted Aug 07, 2018 - 13:55 PDT
Investigating
We are aware and investigating an issue that is impacting our audit service.
Posted Aug 07, 2018 - 10:34 PDT
This incident affected: Expense Audit (Expense Audit).